Improving Hawken Crossfire & Vsync Performance

Posted: November 9th, 2012 | Author: | Filed under: Crossfire Scaling, Hardware, Software, Tips/Tutorials
Tags: , , , , ,

UPDATE3: After poking inside the CAP file from 13.2 beta 6, I noticed they finally changed the profile to HawkenGame*.exe, so my crossfire fix should no longer be needed (unless you’re using older CAPs of course).

UPDATE2: It seems you dont need to force triple buffering anymore as of the current beta (December 14), so the only thing to do is force the correct driver profile. (still have to force TB on my 570m as of September 2013)

UPDATE: So the new open beta is interesting, the menus are killing performance for me (4870×2 Catalyst 12.6l), but it’s pretty decent in game. Everything is maxed and I appear to be cpu limited (q9550 at 3.6ghz). Moving around does result in lower framerates like the closed alpha and beta, but maybe it’s a bit more stable now. Also, lowering resolution increases performance when not cpu limited, compared to before where for some reason it ran fastest for me at 1920×1200 native. So try the open beta, do not be alarmed at the awful menu and garage framerates, just start the tutorial or play a match, and remember to force triple buffering if using vsync.

Seems like this is another odd case of poor vsync coming from a recent Unreal Engine 3 game. So if you want to play Hawken with vsync, you better force triple buffering in D3DOverrider, RadeonPro, or similar programs.

As for the driver profile, the exe name is incorrect. The current beta and previous alpha are HawkenGame-Win32-Shipping.exe, while the driver is expecting just HawkenGame.exe. Maybe the developer renamed the game exe recently, oh well.

So what you want to do is either rename your game exe to HawkenGame.exe, or make a crossfire profile in CCC/RadeonPro to load the driver’s Hawken profile.

Last Modified: September 23rd, 2013

3 Comments »

3 Comments on “Improving Hawken Crossfire & Vsync Performance”

  1. 1 womb said at 12:26 pm on November 9th, 2012:

    you sir, are my heroe. all i did was adding the exec. to the nvidia profiles and i’m running a 100% smooth hawken now

  2. 2 Culex said at 6:56 pm on November 29th, 2012:

    Agreed with womb. You are awesome. I thought that the game just wasn’t optimized for crossfire (and it probably isn’t) but I was forced to play on low just to TRY and keep my frames between 30 and 60. I just tested this, and indeed it is working now like a charm. Looks as if I was playing on a single card the entire time. This information needs to get out. Props again for discovering this!

  3. 3 kn00tcn said at 8:06 pm on November 30th, 2012:

    @Culex, dont forget about the vsync part, it affects several UE3 games by now, including single gpus


Leave a Reply